Laravel 5 Repositories

Analytics

Some changes between version 2.0 and 2.1

Migrate from version 2.0 to 2.1

Lumen Support

To use this package with Lumen , register the following service provider

$app->register(Prettus\Repository\Providers\LumenRepositoryServiceProvider::class);

Composer requirements

In version 2.0 some dependencies that could sometimes not be used in your project were always being downloaded regardless of whether they are used. In version 2.1 this package are as suggestions that will only be required if you want some features

Validators

If you want to use validations directly to your repository, as is disbelieved in Section Validators , you need to use the library prettus/laravel-validator.

composer require prettus/laravel-validator

Presenters

If you want to use presenters in your repository, you need to use the library league/fractal.

composer require league/fractal